You really did nail it. I had some sort of error trying to get to the ASCOM control for the Pyxis in the Rotator Controller, but I was able to get to it through Maxim and change the checkbox to reverse. That solved the core problem. Thanks for your help.

Now I still have a quibble. On my test run, it went to M33, checked positioning, moved and rotated, and started the first exposure. This exposure was not centered. After the first exposure, it corrected the centering and a that point it was perfect. I would think that an additional check exposure before assuming you are centered would be a good idea. But that's a suggestion, not a bug.

BTW, it does turn out that my first post was correct. I had an incorrect setting in the configuration. And now I've found it.