Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Hybrid View

  1. #1
    Join Date
    Feb 2021
    Location
    Bethany, CT
    Posts
    120

    Default FLI Centerline Struggles - AND THE SOLUTION

    [RBD edit - This describes how to get the Centerline set up just the way you want]

    So I attempted to run the filter focus offset i see several issues here in the log. one issue is it can't seem to move to filters about 10.
    So in my case 11 and 16 failed. It also had issues pulling information on base exposures, weird stuff.
    Attached Files Attached Files
    Last edited by Bob Denny; Mar 8, 2021 at 16:47.

  2. #2
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    29,754

    Default

    Richard, I am just about finished with the Centerline filter wheel from MaxIm and ultimately FLI. Are you still using the ASCOM filter wheel and camera drivers? I am so confused between your issues and Gary Walker's by now. I've been on for multiple hours with both of you chasing FLI Centerline craziness. I think it was on your system Sunday that I looked at the list of filters and there were 9 or 10 of them listed? What the hell are 11 and 16??? I think these are raw numbers coming from the Centerline through MaxIm that are disconnected from the numbers that I get when asking MaxIm for the list of filters in the first place.

    Why sis this craziness "just start" in the last few weeks? I now why Gary got zapped. He has a filter in "raw" slot 13 that is reported in the FilterList as 9. That disconnect drives my logic crazy! Is it 9 or 13??? He had never used that filter until last week and that set off the craziness. In your case, same craziness. I will call in again and look again, but I am 99% certain that MaxIm is returning filters with numbers in FilterList that are different from the number you get after selecting a filter and then later reading it back. I am not about to implement a system for maintaining two separate filter/number lists!!

    Looking at your logs I am 99% certain that SII and OIII are not in the positions that they are in the filter list coming from MaxIm. There is a "gap" in there. and I have no way to know what physical positions they occupy. All I have to go on is the CCDCamera.FilterList. I count filters using that.

    I know you are busy so let me know when I can call in and validate my 99% suspicion.
    -- Bob

  3. #3
    Join Date
    Feb 2021
    Location
    Bethany, CT
    Posts
    120

    Default

    Thanks Bob My guess is that many people move to this centerline wheel that have the Planewave L-mounts. The reason being because it distributes the weight evenly so no matter how you rotate it the balance of the mount stays constant, this is important for the L-Series. They only have a maximum of 3 amps for the drive motors and you need to account for the both axis of the mount so really 1.5 amp max load. Its not really a problem if you balance your system well but it takes a bit of understanding on how to balance 3 axis instead of 2. I can do 11:45 EST today and I'll have time to spend then.

  4. #4
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    29,754

    Default

    Hi again — I am 99% sure I know what’s happening. I read the list of filters (by name) coming from MaxIm. That info comes from the Setup Filters list in MaxIm (Camera.FilterNames). I get a contiguous list. Throughout I use the numbers and names for various purposes. There are places where I look at which filter MaxIm currently reports as being selected... and make decisions. This way I can avoid having to create a software “shadow filter wheel” which follows the real one. Unfortunately the number I get from reading “currently selected filter” (Camera.Filter) is the “raw” number. If there is a gap, the index in the list and the current filter number don’t match and that’s what creates the confusion you’re seeing.
    -- Bob

  5. #5
    Join Date
    Feb 2021
    Location
    Bethany, CT
    Posts
    120

    Default

    I had a chat yesterday with Steve Brady, I had sent him the FoucsMax logs from the filter offset fail. He indicated to me that the new FocusMax 5 will have a filter offset routine built in. He suggested I just use that one. Looks like he will be releasing the beta version in the next week or so. It will be a good test to see if it finds all the filters from this FLI centerline. I completed the FOVI and verified that its correct, and I tested guiding in Maxim and have that working pretty well now. I might give multi-star guiding a go and compare it.

  6. #6
    Join Date
    Feb 2021
    Location
    Bethany, CT
    Posts
    120

    Default

    Bob I have no more meetings for the rest of the day, you can reach out anytime.
    Thanks

  7. #7
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    29,754

    Default

    Be careful with the filter offsets in FOcusMax, vs MaxIm, vs ACP. They could all fight each other. I recommend the ACP offsets as you can also control the star brightness used for focus (not using AcquireStar) and you can control the reference filter. ACP needs that FilterInfo file in order not to focus on every filter change.
    -- Bob

  8. #8
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    29,754

    Default Filter Offset Run fails

    I have posted this to the MaxIm forum

    https://forum.diffractionlimited.com...nterline.8176/
    -- Bob

  9. #9
    Join Date
    Feb 2021
    Location
    Bethany, CT
    Posts
    120

    Default

    Thanks - for posting that. I'm glad you're helping me through this, if you weren't here or willing to help I would have given up by now. I know the benefits of using ACP, and I love the product but in my case its so hard to get there. Thank You Bob.

  10. #10
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    29,754

    Default

    Well "hard to get there" isn't due to ACP limitations or bugs, in your case two crazy issues with FLI: (1) Camera reports 0 for its pixel size, and (2) filter wheel numbering disconnects as seen from MaxIm. Thanks for hanging in there!
    -- Bob

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Filter error FLI Centerline - Inconsistent filter numbers reading and writing
    By Gary Walker in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 19
    Last Post: Mar 15, 2021, 19:42
  2. FLI CenterLine Filter Wheel Problems
    By Richard Asarisi in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 32
    Last Post: Mar 2, 2021, 23:41
  3. FLI Kepler under MaxIM
    By Paul Luckas in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 2
    Last Post: Nov 8, 2019, 17:54
  4. Problem connecting FLI camera - Requires PC reset
    By Marco Lorenzi in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 1
    Last Post: Oct 7, 2013, 18:06

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •