Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Hybrid View

  1. #1

    Default Filter error FLI Centerline - Inconsistent filter numbers reading and writing

    Hello--Got this filter error last night for a new plan--got the same error for an old plan that has run several times. The log is also below:

    Imaging to 20210226_Plan HD143352_015sec_V_001_2459272_094708
    **Bad filter number 13, returning D.
    Switching from D to V filter for imaging
    Subscript out of range: 'Util.ScriptCamera.Filter'




    I did a resubmit and the next plan: ACP Says:


    Status: Failed
    Subscript out of range: 'Util.ScriptCamera.Filter'





    This is the log from the original error:

    ACP console log opened 27-Feb-2021 05:00:04 UTC
    This is ACP version 8.2 (build 6, V8.2 Pre-Release)
    Licensed to Gary E Walker
    05:00:04 This is AcquireScheduler V8.2.5
    05:00:04 Custom image file path/names are in use
    05:00:05 Initializing AcquireSupport V8.2.7
    05:00:05 Weather safe, server is SRO Roof Status & Weather System
    05:00:05 Telescope is ACP->PlaneWave CDK 20 0.5m f/6.8, driver V3
    05:00:06 MaxIm DL is version 6.16
    05:00:06 Imager is ASCOM
    05:00:06 Using focus offsets and star mags from FilterInfo.txt
    05:00:06 Selecting filter SI from previous ACP run at 20210226@141220 UTC
    05:00:06 Autoguiding is disabled
    05:00:06 Calculated unbinned plate scales (arcsec/pix): H = 0.66 V = 0.66
    05:00:06 Calculated field of view (arcmin): H = 22.4 V = 22.4
    05:00:06 Plate solving with UCAC4 (questionable for pointing)
    05:00:06 Scope cannot be synced, so all-sky solving is not useful
    05:00:06 ACPS Observation Obs EP Aur(1 of 1)
    05:00:06 (belongs to Project Project GW EP Aur, Plan Plan EP Aur)
    05:00:06 (turning on sidereal tracking)
    05:00:06 Pointing Updates are disabled
    05:00:06 (final image plate solving is disabled)
    05:00:06 Start slew to Obs EP Aur...
    05:00:07 (wait for slew to complete)
    05:00:22 (slew complete)
    05:00:22 Imaging to 20210226_Plan EP Aur_120sec_B_001_2459272_050022
    05:00:22 **Bad filter number 13, returning D.
    05:00:22 Switching from D to B filter for imaging
    05:00:22 Subscript out of range: 'Util.ScriptCamera.Filter'
    ACP console log closed 27-Feb-2021 05:00:22 UTC



    This plan is using BVRI and Clear, same ones as I have used for several years. I did change the autoflat script to use SI instead of Exo for a flat in the morning. Other than that, ran fine for the past
    couple days.

    Gary

  2. #2
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    29,824

    Default

    Did this "just start happening"? No changes to the system? No one changed filter wheels or filter assignments or ??? Normally, when ACP connects to the Camera, it immediately reads the list of filters from MaxIm and populates the filter lists in the submission forms with that.

    I also need complete log files not snippets please. Attach the complete log files. <-- link to attaching instructions
    -- Bob

  3. #3

    Default

    Yes this just started happening. I think that I did paste the complete log, as this error happened almost immediately after it started to observe on a fixed time bases at 5:00UTC. If this is not the log you are looking for, where is it located? I will attach it.
    Thanks

  4. #4

    Default

    Hi Bob: It just happend on startup tonight again.

    Paste of what was in ACP.

    This is AcquireScheduler V8.2.5
    Custom image file path/names are in use
    Initializing AcquireSupport V8.2.7
    Weather safe, server is SRO Roof Status & Weather System
    Telescope is ACP->PlaneWave CDK 20 0.5m f/6.8, driver V3
    MaxIm DL is version 6.16
    Imager is ASCOM
    Using focus offsets and star mags from FilterInfo.txt
    Selecting filter SI from previous ACP run at 20210226@141220 UTC
    Autoguiding is disabled
    Calculated unbinned plate scales (arcsec/pix): H = 0.66 V = 0.66
    Calculated field of view (arcmin): H = 22.4 V = 22.4
    Plate solving with UCAC4 (questionable for pointing)
    Scope cannot be synced, so all-sky solving is not useful
    ACPS Observation OJ287(1 of 1)
    (belongs to Project Project LFB_AGNs, Plan OJ287)
    (turning on sidereal tracking)
    Pointing Updates are disabled
    (final image plate solving is disabled)
    Start slew to OJ287...
    (wait for slew to complete)
    (slew complete)
    Imaging to 20210227_OJ287_030sec_D_001_2459273_021833
    **Bad filter number 13, returning D.
    Switching from D to D filter for imaging
    Subscript out of range: 'Util.ScriptCamera.Filter'


    This plan ran last night or the night before. Only change was a power cycle of the filter wheel.

    Is this the detailed log you are looking for? If not, again, can you point me to the one you are looking for?

  5. #5
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    29,824

    Default

    Gary please post the log as an attachment. <-- link to attaching instructions

    Is this the detailed log you are looking for? If not, again, can you point me to the one you are looking for?
    No this appears to have been cut out of the ACP console. The logs are located (assuming this is not a remote user) at [My] Documents\ASP Astronomy\Logs\Scheduler\ddddmmyy@hhmmss ... and I don't k ow what the date/time is because the real logs are time stamped on every line. The logs are available in the web schedule browser as well. Drill down from Project to Plan to Observation which is the ACP run. The log should be linked to a completed Observation. If you want me to hop on and guide you through this OK. Just let me know. George knows all about this.

    Nonetheless this is somewhat of a help. Now I need to see the Project LFB_AGNs, Plan OJ287, Observation OJ287(1 of 1). Look in the Schedule Browser. You will find that the D filter is selected. Now look at MaxIm's Camera Control. What filters are shown there? Is D included? Did D move from one slot to the next? Are there even 13 filters (or more) listed there. What filters are listed in the ACP submission forms (web, scheduled)? Are there 13 or more filters listed there?

    Is the filter wheel a FLI Centerline? I have had a flurry of problems crop up because MaxIm is not providing a consistent list of filter names. And the slots and filters are disjointed etc. Could this be related? Really... have there been any MaxIm or FLI driver updates? That would be vitally important. Software doesn't "just stop working" Something changed. Help me.
    -- Bob

  6. #6

    Default

    Hello Bob
    Looked at these logs and the first instance of this error actually occurred on my project "DuskDarks". I have pasted the log entries below--not a lot of them, and they do look like the ACP Console entry above. You may have hit the problem--Yes this is a FLI Centerline FW. No conscious updates on my part. We did power cycle the filter wheel, on 0225, but it observed fine that night. Problem started on 0226. We did this because the FW lost home position. Do you find that FLI does automatic filter updates? Also Maxim is 6.16--no conscious changes there on my part. Win10 updates turned off. There are 14 filter positions. Nothing listed at position 13--its just blank.

    In Maxim Camera Control, there is a D filter listed. Some filters are blank as they have no filter. No change in slots in the filters. The ACP Submission for the "DuskDark" only uses the Dark filter (CMOS). The OJ287 plan that I pasted before only has D, R, and V (this is from memory--have to double check)

    ACP console log opened 27-Feb-2021 02:15:43 UTC
    This is ACP version 8.2 (build 6, V8.2 Pre-Release)
    Licensed to Gary E Walker
    02:15:43 This is AcquireScheduler V8.2.5
    02:15:43 Custom image file path/names are in use
    02:15:44 Initializing AcquireSupport V8.2.7
    02:15:44 Weather safe, server is SRO Roof Status & Weather System
    02:15:44 Telescope is ACP->PlaneWave CDK 20 0.5m f/6.8, driver V3
    02:15:44 MaxIm DL is version 6.16
    02:15:44 Imager is ASCOM
    02:15:44 Using focus offsets and star mags from FilterInfo.txt
    02:15:44 Selecting filter SI from previous ACP run at 20210226@141220 UTC
    02:15:44 Autoguiding is disabled
    02:15:44 Calculated unbinned plate scales (arcsec/pix): H = 0.66 V = 0.66
    02:15:44 Calculated field of view (arcmin): H = 22.4 V = 22.4
    02:15:44 Plate solving with UCAC4 (questionable for pointing)
    02:15:44 Scope cannot be synced, so all-sky solving is not useful
    02:15:44 ACPS Observation DuskDark(1 of 1)
    02:15:44 (belongs to Project DuskDarks, Plan DuskDark)
    02:15:44 (turning on sidereal tracking)
    02:15:44 Pointing Updates are disabled
    02:15:44 (final image plate solving is disabled)
    02:15:44 Start slew to DuskDark...
    02:15:45 (wait for slew to complete)
    02:16:10 (slew complete)
    02:16:10 Imaging to 20210226_DuskDark_000sec_D_001_2459272_021610
    02:16:11 **Bad filter number 13, returning D.
    02:16:11 Switching from D to D filter for imaging
    02:16:11 Subscript out of range: 'Util.ScriptCamera.Filter'
    ACP console log closed 27-Feb-2021 02:16:11 UTC

    I have no idea why its calling out the SI filter. None of these plans call for it.

    Right now Scheduler is running the EP Aur plan, listed at 100% complete, but locked up in "Running". Also, cannot change the start stop times as there is no "Save Changes" showing. I did make a mistake and apparently did not update the run before date, so the run date is Feb 28 and the run before date is Feb 27. Could this be the problem also?

    BTW: While I am associated with AAVSO and George and AAVSOnet, this is my private install, and not an AAVSO license.

    Thanks for your help

  7. #7
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    29,824

    Default

    I have pasted the log entries below--not a lot of them, and they do look like the ACP Console entry above.
    I see only one pasted log. I'm unsure what you mean by "entries".

    It's also hard for me to support old versions of ACP, I have to retrieve the old outdated scripts (s) from the repository so I can work with the source code you are running. You do have current support and upgrades (thank you!!).

    The error is a result of ACP trying to convert the filter number (13) that was selected as the Dark filter in your ImageSet. Instead, ACP is falling back to the "ClearFilter that is set here:



    This is confusing to me. I'm going to need to look myself at your Plan, your MaxIm filter setup. and what filter info is in the images in your plan. Somewhere tings changed and ACP is looking for a filter 13 and now it sees that there are only 12 or fewer filters.

    It's Sunday (what am I doing here ha ha ha???) I'll try to call.

    [edit] I called and left voicemail. Let me know when we can get together I need to look at this rather than ask you a bunch of questions.
    -- Bob

  8. #8

    Default

    Hello Bob
    I can be available most all day Monday. Lets try for 10am MST/12 noon EST?
    Gary

  9. #9
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    29,824

    Default

    One and a half hours. FLI Centerline wheel. Using filter 13 in MaxIm/FLI with from filter 9. ACP sees the list of filters from MaxIm as having 10 filters and can successfully select the 10th filter (number 9). However later, the wheel reports that same filter as having number 13 and when ACP goes to log the filter used by name it tries to translate the 13 coming from the wheel and there is no translation. Inconsistency in the filter numbers due to a bug in the very old 2008 FLI plugin for MaxIm. I learned yesterday that the newer FLI ASCOM filter wheel driver is the one to use. Although it appears that an ASCOM filter wheel driver is installed it did not see the filter wheel. We don't know if that is the latest ASCOM filter wheel driver and we could not find one listed in the FLI web site. Then the filter wheel disappeared from the COM port list and even the old driver couldn't see it. He cannot (yet) power cycle the filter wheel. At this point we are stuck until the Sierra Remote Techs can restart the filter wheel.
    -- Bob

  10. #10
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    29,824

    Default

    FYI here's the one from yesterday Calling MaximDL Filters from ACP Fails
    -- Bob

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Old FLI Filter plugin causes limit in the number of filters during a flat field?
    By Stephane Basa in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 9
    Last Post: Feb 17, 2021, 16:58

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •