Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Hybrid View

  1. #1

    Default Web interface for Scheduler

    I'm a recent convert to ACP - some travails with Maxim in CCDAP has led me to switch over. I'm amazed by the range of features available in ACP. So I've taken the plunge.

    I'm wrestling with Scheduler and have been holding off making that purchase till I can get it running during the trial period. I have a few "wrinkles" that I'd like to iron out.

    1. I have set up a Project complete with plans and observations in Scheduler and attempted to run it in simulation mode. It simulates dusk and dawn flats but not imaging itself. Rather the log suggests that there are no plans available. So I generated a Test Project - same result. Looking at the UTC Date, I can't shift it past 31 December 2014. I'm wondering whether this is why the simulator won't run. As the projects are generated now (April 2015), Scheduler won't recognise the projects back in December 2014. Each time I set the UTC Date to the Current Date/Time, I receive an Unhandled exception error. I've attached a screenshot. Is this as expected?

    2. The Help files direct astroimagers to use the web browser interface for Scheduler. Moving to the local web interface in ACP, I click on the Schedule Browser link and in turn move to the Submit Astro-Imaging Request tab. This in turn directs me back to the main ACP browser's Astro-Imaging tab. Clicking on that, I complete the required fields. A screenshot is attached. Submitting that, I receive an error message stating that the filter is empty. Again, a screenshot is attached. Reading the help files, I see that I need to complete the filter.txt file - which I have duly done. I assume that the browser draws on this file to populate the drop down box for the filter field. TO be sure I have this right, I've attached a screenshot of this file. So how do I overcome this? Is there another file somewhere that needs to be completed?

    3. As an alternative, I turned to the Schedule Image Series alternative in the browser. There is a screenshot showing my test series. However, when I submit this, I receive a new error message suggesting that I have not included an image name - even though it is clearly included. Again, another screenshot.

    I expect that there is a funky setting somewhere that I have yet to activate - or there is some other instance of operator error. I would appreciate any tips on where I am going wrong. The functionality of Scheduler sounds fantastic - if I can get to it.



  2. #2


    OK I have made some progress

    I downloaded the new release of Scheduler which has fixed the date - I can now operate in 2015 so I am up to date rather than behind the times (as my child infrequently assert).

    I've also found that I need to submit plans to get Scheduler to recognise them - even after I have saved them.

    After doing this, I have been able to run a few auto generated plans and a simple plan that I devised. So far so good. But...

    A plan that consists of 3 x 5 x 5 minute subs doesn't start because Scheduler doesn't believe here is enough time for the target to be imaged. The target is in the southern sky (I'm in Australia) and should be available for most of the night. Perhaps I don't have the time set correctly.

    Now I am finding that the Scheduler simulator has decided to run in real time not accelerated time. After it ticks along for a while it calls for Operator intervention. I need to shut it down and restart. Same issue. Restarting the computer makes no difference.

    I now plan to roll back to the previous release of Scheduler as I fear the new version (which admittedly is a beta test) has bugs.

    BTW, the new Web Interface in Scheduler is better than the old one but the new version of the program doesn't address the web interface through the standard ACP web interface.

    Any suggestions are most welcome


  3. #3


    A further update - roll back to the previous version of Scheduler was not a good move.

    After starting the simulator, the clock remained at standard time (ie no acceleration). It then reported a "serious error - handling" and the status of Scheduler changed to "Dead" - very ominous!

    Also, trying to activate the Web interface, Scheduler reports that while this is a trial version of the program, there are multiple users. Not sure how that happened!

    Here is the log
    Log opened at Sat, Apr 04 2015 01:44:27 UTC (actual time)
    Current log level is Debug
    Scheduler version 3.7.3
    Time-limited evaluation mode (46 days left)
    30-Mar-2014 09:05:26.0: Simulated clock initialized at 30-Mar-2014 09:05:26 UTC
    30-Mar-2014 09:05:26.0: Loaded Constraint plugin AirMass
    30-Mar-2014 09:05:26.0: Loaded Constraint plugin AirmassRange
    30-Mar-2014 09:05:26.0: Loaded Constraint plugin Horizon
    30-Mar-2014 09:05:26.0: Loaded Constraint plugin HourAngle
    30-Mar-2014 09:05:26.0: Loaded Constraint plugin MoonAvoid
    30-Mar-2014 09:05:26.0: Loaded Constraint plugin MoonDown
    30-Mar-2014 09:05:26.0: Loaded Constraint plugin SkyCondition
    30-Mar-2014 09:05:26.0: Loaded Constraint plugin TimeRange
    30-Mar-2014 09:05:26.0: 4 plans are now pending.
    30-Mar-2014 09:05:26.0: Attach Simulator sequencer
    30-Mar-2014 09:05:26.0: Sequencer does sky flats
    04-Apr-2015 01:44:34.7: Clock changed to real-time
    04-Apr-2015 01:44:34.8: Release Simulator sequencer
    04-Apr-2015 01:44:34.8: Attach ACP sequencer
    04-Apr-2015 01:44:44.6: Weather successfully connected. Wait for valid data...
    04-Apr-2015 01:44:49.6: -- Weather Unsafe --
    04-Apr-2015 01:46:12.9: Dispatcher started at 04-Apr-2015 01:46:12 UTC
    04-Apr-2015 01:46:12.9: Priority: W[0]=1.00
    04-Apr-2015 01:46:12.9: Transit Altitude: W[1]=0.70
    04-Apr-2015 01:46:12.9: Highest Altitude: W[6]=0.00
    04-Apr-2015 01:46:12.9: Lateness: W[5]=0.00
    04-Apr-2015 01:46:12.9: Slew Distance: W[2]=0.00
    04-Apr-2015 01:46:12.9: Retry Count: W[3]=0.20
    04-Apr-2015 01:46:12.9: Meridian Crossing: W[4]=0.00
    04-Apr-2015 01:46:12.9: Obs Conditions: W[7]=0.40
    04-Apr-2015 01:46:12.9: Rising Plan Delay: in effect
    04-Apr-2015 01:46:21.1: Dispatcher stopped at 04-Apr-2015 01:46:21 UTC
    04-Apr-2015 01:46:21.1: **DISPATCHER INTERRUPT LEVEL 1 RECEIVED**
    30-Mar-2014 09:05:26.0: Clock changed to simulated time
    30-Mar-2014 09:05:26.0: Simulated clock time changed to 30-Mar-2014 09:05:26 UTC
    30-Mar-2014 09:05:26.0: Release ACP sequencer
    30-Mar-2014 09:05:26.0: Attach Simulator sequencer
    30-Mar-2014 09:05:26.0: ++ Weather Safe ++
    30-Mar-2014 09:05:26.0: Simulated clock started
    30-Mar-2014 09:05:26.0: Dispatcher started at 30-Mar-2014 09:05:26 UTC
    30-Mar-2014 09:05:26.0: Priority: W[0]=1.00
    30-Mar-2014 09:05:26.0: Transit Altitude: W[1]=0.70
    30-Mar-2014 09:05:26.0: Highest Altitude: W[6]=0.00
    30-Mar-2014 09:05:26.0: Lateness: W[5]=0.00
    30-Mar-2014 09:05:26.0: Slew Distance: W[2]=0.00
    30-Mar-2014 09:05:26.0: Retry Count: W[3]=0.20
    30-Mar-2014 09:05:26.0: Meridian Crossing: W[4]=0.00
    30-Mar-2014 09:05:26.0: Obs Conditions: W[7]=0.40
    30-Mar-2014 09:05:26.0: Rising Plan Delay: in effect
    30-Mar-2014 09:05:26.0: ++ Observatory Startup ++
    30-Mar-2014 09:05:26.0: (wants the dome opened after startup)
    30-Mar-2014 09:05:26.0: [sim] Startup script would run now.
    30-Mar-2014 09:10:26.0: [sim] Open the observatory dome/roof
    30-Mar-2014 09:15:26.2: **EXCEPTION IN SCHEDULER:
    30-Mar-2014 09:15:26.2: Single-user license or trial period, yet database has multiple users. Cannot continue.
    30-Mar-2014 09:15:26.2: Traceback:
    at DC3.Scheduler.Engine.DoSchedulePass()
    at DC3.Scheduler.Engine.Run()
    30-Mar-2014 09:15:26.2: Release Simulator sequencer
    30-Mar-2014 09:15:27.6: Simulated clock stopped
    Log closed at Sat, Apr 04 2015 01:46:42 UTC (actual time)

    All gobbledygook to me. But I am sure Bob will understand


  4. #4


    I think I understand how the "multiple user" error arose. when trying to adjust the sample plans I had prepared to enable them to be run in the simulator, I set up a new Project. However, I failed to set myself as the observer - so Scheduler thought there were 2 observers - me and the Observatory Operator. This was inconsistent with the program evaluation terms and - perhaps - has locked up the simulator.

    I'd love o know how to extract myself from this. With Easter now (and plenty of rain here in Aus at the moment) I am happy to wait for guidance.


  5. #5
    Join Date
    Oct 2005
    Mesa, AZ


    Yes it is Easter weekend, and I am only in here for an hour or two this morning. It has been a very busy week here.

    As always I recommend against uninstall/reinstall cycles as a troubleshooting tool, and I never design my software to be back-revved (no one does). It is always good to run on the current version of software... I'm sorry you got the test/pre-release version then lost faith in it. Looking at the Scheduler logs might give you cliuse.

    I would now suggest you start from scratch because I don't know how to extricate you from what are bound to be multiple shots in the dark, some of which you have forgotten about or don't want to talk about (haha). I'm not judging yo here, just being pragmatic. I can't be here all weekend to help you as we have plans. So, to do a ground zero start:

    1. Download the current Production Scheduler. <-- Link to the page
    2. Using the control panel, uninstall your current Scheduler
    3. Remove all of the files in c:\Program Files (x86)\ACP Scheduler (maybe cave copies of them but probably not needed)
    4. Now install Scheduler 3.7a
    5. Start the Scheduler to initialize the constraint tables. Leave it running and...
    6. ... switch to Simulator, then exit from scheduler and restart it.

    Now try to use it. First, enter your requests through the main web user interface, Scheduled section, not the Schedule Browser.

    If you have problems, post them here. Someone besides myself might answer before Monday. I do my best to provide support but I'm not an ER doc :-) :-)
    -- Bob

  6. #6



    thanks for responding - especially at Easter. I hadn't intended to have you interrupt your other tasks to respond but I am grateful.

    I've started from scratch as you suggested. I'll be back in touch in a few days with any queries


  7. #7


    I thought I'd post some good news. I've managed to get Scheduler working with my set up. A fresh start and carefully working through the Help files and experimenting has paid off. I managed a run - or the beginning of one last night until I had a guide failure. That's another story. Im just pleased that I have it operational now.

    Here are some things that proved troublesome - again, probably pilot error rather than software issues.

    One initial issue I had was that plans around the SCP wouldn't run in the simulator. I checked the latitude setting in the Sim section of the Configuration file there and it was correct. Nevertheless, with the minimum horizon set to 30 degrees, anything below Dec -20 just wouldn't run. So I shut down Scheduler and restarted it and then found the plans would run. It seems that the changes to the Configuration file wouldn't register until it had been shut down and restarted. After that, the simulator worked like a charm.

    I populated plans using the web browser - linked via the main ACP browser. I built up the plans manually - in a similar fashion to the Scheduler Browser. The AstroImaging and Single Series options listed under Scheduler in the main ACP browser window don't work for me. This was covered in my first post.

    The other odd issue was that I had trouble shifting from Simulator to Normal (ACP Sequencer) mode. Clicking from one option to the other and restarting the Despatcher didn't shift the clock. Looking at the logs, the simulator clock continued to run. I was able to shift it by selecting Day/Night (ACP Sequencer) and restarting the Despatcher and then stopping it, changing to Normal mode and restarting the Despatcher. That sorted it.

    It was a delight to assemble a series of projects and plans and to run them in the simulation mode. Even more pleasing was then switching it over to Normal mode and seeing the plan commence in the same way in real time.

    I'm going to enjoy this method of imaging!


  8. #8
    Join Date
    Oct 2005
    Mesa, AZ


    Sounds encouraging, and thanks for the details! I'd like to help on this

    The AstroImaging and Single Series options listed under Scheduler in the main ACP browser window don't work for me. This was covered in my first post.
    The first thing I noticed in your original post was a submission via the Single Series form that specified a run with 21,600 minutes of imaging time. This is a 360 hour run! The Single Series seems to attract people because it's more like the "old ways" but it's more there for science people who need to take a series of images for photometry etc. Anyway, 360 hours can't obviously fit into a night. I see you tried the Astro Imaging form as well. I can't tell for which one of the three forms images the error popup (web) appeared. Can you give me a repro scenaro for that?

    Also I can't tie the other two images showing problems to any action on your part so I don't really know what to do with them either.

    Or are you not having those problems now? Or different ones?
    -- Bob

  9. #9


    Thanks for the reply Bob

    I'll post some screenshots when I am at home this evening - its a bit trickier to do this from my office computer. The errors arose irrespective of the time allocated to imaging runs.

    Now I understand how to prepare projects in the Project Browser (accessed via the ACP main browser), I really don't need to use either the Astro-Imaging or Single Series options in the ACP main browser. I reported this for information purposes only.


  10. #10
    Join Date
    Oct 2005
    Mesa, AZ


    Be careful of the Schedule Browser. It's easy to make giant projects that basically eliminate the need for a scheduler, and at worst are impossible to have run.

    If you think it's easier to use the Schedule Browser to enter requests, compared to the forms I supply, then I know I want to talk to you. I am missing something possibly very important.
    -- Bob



Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Web interface
    By Kevin Hill in forum Pre-Sales Technical Questions and Help
    Replies: 8
    Last Post: Mar 1, 2014, 16:39
  2. web interface
    By flyrcairplanes in forum Pre-Sales Technical Questions and Help
    Replies: 1
    Last Post: Oct 19, 2009, 01:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts