Results 1 to 4 of 4
  1. Default Script Engine Load Error

    Bob,

    After a bad experience attempting to install the Kaspersky Security Suite on my SRO observatory machine, I am now getting the following error whenever I try to run a script from the ACP Console:

    ACP script error 0x8007007E from ThinScript.ActiveScript:
    Creating the ActiveX Scripting engine failed. Scripting engine is probably not correctly registered or CLSID incorrect..

    Any suggestions about how I can recover?

    Thanks,
    Larry

  2. #2
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    28,296

    Default

    I'm guessing that Kaspersky has somehow prohibited any Windows Scripts from running, perhaps by prohibiting the creation of any Windows Script engines. Some of the security systems I have encountered have that option. I look at Kaspersky's site and found this. I don't know if this is it but it's something to look at:

    http://support.kaspersky.com/5419

    Anyway my error message from ThinScript (Scripting engine is probably not correctly registered or CLSID incorrect) is a guess. The important thing is that my scripting host can't create an instance of the script engine. The engines are part of the Windows OS and are supposed to be "always there".

    I hope this helps.
    -- Bob

  3. Default

    Hi Bob,

    Thanks for the suggestion. Turns out the Kaspersky install replaces the standard vbscript.dll vector in the registry with its own pointer and when the installation went bad that did not get cleaned up. Replacing the registry entry with the right pointer to vbscript.dll fixed the problem.

    Larry

  4. #4
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    28,296

    Default

    Ok, good to know. Suspect this if there are scripting problems in the future. ACP makes assumptions about the abilities of VBScript and JScript as they are supplied with Windows (XP/7/8).
    -- Bob

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Active X script error in script with FocusMax
    By Paul Burke in forum FocusMax and PoleAlignMax Questions
    Replies: 1
    Last Post: Oct 29, 2013, 23:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •