Bob:

I had a major anomaly last night, and canít get ACP working at all. In a nutshell, whenever you try to do an autofocus three things happen:

1) ACP logs a Microsoft VBScript runtime error, Message: Input past end of file at line 810 column 5. (See Document 1, ACP Log)
2) The ACP Console reports: **Script Error (Tracking has been stopped)** Source: Microsoft VBScript runtime error, Message: Input past end of file at line 40 column 5. (See Document 2, ACP Console)
3) FocusMax Log reports: ** Telescope is not connected **. (See Document 3.)

So, for some reason, FocusMax is reporting that it cannot connect to the telescope. I tested this, and there is no physical connection problem. MaximDL can connect to the telescope, FocusMax can connect to the telescope, and when I click the ďFocusĒ button within FocusMax, FocusMax is working fine. So each program can connect to the telescope. But when I connect the Camera and Telescope to ACP, the connection between FMax and the telescope is not taking place.

Iíve upgraded to ACP 7.1d, and am wondering if there is a driver problem somewhere. But, in a nutshell, Maxim and FocusMax have no problem connecting to the telescope. But when ACP connects everything together, FocusMax doesnít seem to be getting the telescope information that it needs. The problem is easy to test. If ACP is connected and you try to run the autofocus.vbs script, it hangs every time.

This all occurred when I was trying to test the ACP Scheduler last night. When the error occurs, ACP seemed to stop but did not close the dome. So Iím wondering why that didnít happen, but thatís a separate question.

Thanks,

Rob


Document 1. ACP Log: This occurs when you try to do an autofocus through ACP

ACP console log opened 09-May-2014 02:15:19 UTC
This is ACP version 7.2 (build 1, In-progress not released)
Licensed to Robert Capon
02:15:19 This is AcquireScheduler V3.6.3
02:15:19 [PreFlip=300 PostFlip=120 AF=180 PU=60]
02:15:19 Hardware GEM pier side reporting is available.
02:15:21 Initializing AcquireSupport V7.1.4
02:15:21 Weather safe, server is AAG_ACPWeatherFeed (v7.20)
02:15:21 Telescope is ACP->TheSky, driver V2
02:15:21 Dome is Digital DomeWorks
02:15:21 MaxIm DL/CCD is version 5.24
02:15:21 Imager is SBIG Universal
02:15:21 Autoguiding is disabled
02:15:21 Calculated unbinned plate scales (arcsec/pix): H = 0.65 V = 0.65
02:15:21 Calculated field of view (arcmin): H = 43.3 V = 28.9
02:15:21 Using focus offsets and star mags from FilterInfo.txt
02:15:21 **Script Error (Tracking has been stopped)**
02:15:21 Source: Microsoft VBScript runtime error
02:15:21 Message: Input past end of file at line 810 column 5.
ACP console log closed 09-May-2014 02:15:29 UTC


Document 2. ACP is reporting this in the console:

Initializing AcquireSupport V7.1.4
Weather safe, server is AAG_ACPWeatherFeed (v7.20)
Telescope is ACP->TheSky, driver V2
Dome is Digital DomeWorks
MaxIm DL/CCD is version 5.24
Imager is SBIG Universal
Autoguiding is disabled
Calculated unbinned plate scales (arcsec/pix): H = 0.65 V = 0.65
Calculated field of view (arcmin): H = 43.3 V = 28.9
Using focus offsets and star mags from FilterInfo.txt
**Script Error (Tracking has been stopped)**
Source: Microsoft VBScript runtime error
Message: Input past end of file at line 40 column 5.


Document 3. FocusMax Log: Hereís the corresponding FocusMax Log

07:33:02 FocusMax Version 3.8.0.8
07:33:02 ASCOM Platform = 6.0
07:33:02 Regional setting: United States (decimal = '.')
07:33:02 PinPoint is connected
07:33:02 System is RCOS w STL11000_4-1-2014_V cuves w Denny Suggestions
07:33:03 MaxIm DL 5 Error 65535: Could Not Initialize Camera
Module modComponents Property Let camLinkEnabled
07:33:03 MaxIm DL 5 Error 65535: Could Not Initialize Camera
Module modComponents Property Let camLinkEnabled
07:33:03 MaxIm DL 5 Error 65535: Could Not Initialize Camera
Module modComponents Property Let camLinkEnabled
07:33:03 Focuser: RoboFocus is connected
07:33:03 Focuser: RoboFocus is an Absolute Focuser
07:33:03 Position = 5562 Temp = -999.0
07:33:03 Temp. compensation available = False
07:33:03 ** Telescope is not connected **
07:33:03 NOVAS-COM Vector Astrometry Engine is connected