Page 1 of 3 123 LastLast
Results 1 to 10 of 22
  1. #1
    Join Date
    Nov 2005
    Location
    Virgil, NY
    Posts
    5,536

    Default Help with "plans_subdir"

    Bob,

    I'm trying to build an .asp app in which I need to read a directory containing the flats log file(s). I'm using "aacqplan.asp" as a model for this new app. At the beginning of the main script in aacqplan, there is a variable called keyName set to: keyName = "plans_subdir". The Session(keyName) value at this point is (for my setup) "NCG-IC", which is one of the subfolders in the Plans directory.

    In my new script, I've changed all the places where "plans" appears to "logs", and I've changed "plans_subdir" to "logs_subdir". Now several things don't work the same way.

    1. At the beginning of the main script in my app, the keyName is "logs_subdir" but the Session(keyName) value is "", and not one of the subfolders in the log folder. Is "logs_subdir" an unrecognized name?

    2. The window indeed pops up displaying the correct log folder and it has the correct files listed, but when I change to the AutoFlat folder (which I've put in the log folder), the file list doesn't update, and the folder selector reverts to "select subfolder".

    I could use your insight here, if you have a moment to help. How do I enable selecting the log folder and files in them?

    Thanks,
    Dick
    www.VirgilObservatory.us
    Pier-mounted Meade 12-inch SCT "classic"
    Optec TCF-S focuser
    SBIG CFW-8A and ST7-XME
    H-alpha, BVRI, RGB & Clear filters
    FOV ~ 15' x 10'


  2. #2
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    30,766

    Default

    As usual there is more to it. Writing a 'tome' on how the file browsing and subdirectory support works (it interacts with the asp files in plans, logs, images, dirs) is impractical. I will call and try to explain by phone while we're looking at the relevant ASP files. I can't do it tonight, it's my birthday and our anniversary. I could do it tomorrow or Wednesday night.
    -- Bob

  3. #3
    Join Date
    Nov 2005
    Location
    Virgil, NY
    Posts
    5,536

    Default

    Hi Bob,

    I thought I understood the aacqplan script fairly well, including the sweet get/post alternative paths and the file browsing, but I'm obviously missing something. Hopefully a ten-minute chat can clear things up. I don't work (for pay) on Wednesdays. Would it be possible for me to call you at some point during the day on Wednesday? Tuesday evening and Wednesday evening would also work. Do you want to have a copy of my script in hand?

    I should explain that I'm intending to read a flat log file, parse out the TEST and FLAT lines, and use the data to build a graphic displaying to scale the flat exposure times (y-axis) as a function of clock time (x-axis). This would be similar to the spreadsheet graphic I generated for Steve Reilly a few weeks ago, but it would be enabled inside and directly accessible from the ACP environment.

    (reference: http://forums.dc3.com/showthread.php...0138#post40138)
    Dick
    www.VirgilObservatory.us
    Pier-mounted Meade 12-inch SCT "classic"
    Optec TCF-S focuser
    SBIG CFW-8A and ST7-XME
    H-alpha, BVRI, RGB & Clear filters
    FOV ~ 15' x 10'


  4. #4
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    30,766

    Default

    Wow, that would be so great!!! I'll call tomorrow (Wed). How does 11AM your time sound?
    -- Bob

  5. #5
    Join Date
    Nov 2005
    Location
    Virgil, NY
    Posts
    5,536

    Default

    That will be okay. 11 am EDT. Call the cell phone, ends in 3327. Thanks.
    Dick
    www.VirgilObservatory.us
    Pier-mounted Meade 12-inch SCT "classic"
    Optec TCF-S focuser
    SBIG CFW-8A and ST7-XME
    H-alpha, BVRI, RGB & Clear filters
    FOV ~ 15' x 10'


  6. #6
    Join Date
    Nov 2005
    Location
    Virgil, NY
    Posts
    5,536

    Default

    Hi Bob,

    Thanks very much for your help with this application yesterday on the phone. I almost have the file selection script knocked out and running now, but I'm having trouble with converting the following javascript line from aacqplan.asp to vbscipt. I keep getting a compilation error and the compiler error message is useless. The error is in this statement below.

    I know how this is supposed to look, and I understand the javascript, but I'm running into trouble with the vbscript with too many or too few quotation marks in a row, and/or whether to use Chr(34) instead. Could you please reply back with the correct vbscript statement? Are single quotes valid?

    Code:
        Response.Write("<<PostForm \"\" \"/ac/aFlatAnalyzer.asp\" \"Draw Graph\" \"Starts the analysis process\">>");
    And, am I supposed to use "Session" or not?

    Thanks.
    Dick
    www.VirgilObservatory.us
    Pier-mounted Meade 12-inch SCT "classic"
    Optec TCF-S focuser
    SBIG CFW-8A and ST7-XME
    H-alpha, BVRI, RGB & Clear filters
    FOV ~ 15' x 10'


  7. #7
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    30,766

    Default

    It's the quote escaping in JS which needs to be quote doubling in VBS. Let me try...

    Response.Write("<<PostForm """" ""/ac/aFlatAnalyzer.asp"" ""Draw Graph"" ""Starts the analysis process"">>");
    -- Bob

  8. #8
    Join Date
    Nov 2005
    Location
    Virgil, NY
    Posts
    5,536

    Default

    Hi Bob, I need more help with this app. The "Response.Writes" are NOT writing. I'll send you an email. Could we talk again on this coming Wednesday?
    Last edited by Dick Berg; Aug 1, 2013 at 17:45. Reason: added "not"
    Dick
    www.VirgilObservatory.us
    Pier-mounted Meade 12-inch SCT "classic"
    Optec TCF-S focuser
    SBIG CFW-8A and ST7-XME
    H-alpha, BVRI, RGB & Clear filters
    FOV ~ 15' x 10'


  9. #9
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    30,766

    Default

    Maybe tomorrow, but some time this week. The backlog here is my first priority :-) I got your email.
    -- Bob

  10. #10
    Join Date
    Nov 2005
    Location
    Virgil, NY
    Posts
    5,536

    Default

    That's fine, Bob. Thanks.
    Dick
    www.VirgilObservatory.us
    Pier-mounted Meade 12-inch SCT "classic"
    Optec TCF-S focuser
    SBIG CFW-8A and ST7-XME
    H-alpha, BVRI, RGB & Clear filters
    FOV ~ 15' x 10'


 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Solid State Disk Issue (was "ACP Script error while...")
    By rspostrspost in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 7
    Last Post: Oct 2, 2012, 10:14
  2. Tracking Rate Goes from "Stop" to "Tracking" After Darks Plan Initiated
    By Michael Cook in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 4
    Last Post: Apr 3, 2012, 01:39
  3. AP1200 "Rejected Coordinates" (was: Hotfix 9 - Changed ASCOM code?)
    By Mike Dodd in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 4
    Last Post: Nov 2, 2009, 17:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •