Results 1 to 10 of 10

Hybrid View

  1. #1

    Default ACP Crashed twice on me... [Dome issue?]

    Once during a run last night and once just sitting there connected to the dome, scope, camera and weather a few minutes ago with the following error:

    Run-time error '-2147467261 (80004003)
    Object reference not set to an instance of an object.

    It has run flawlessly for a a week before this.

    This usually means a dependent ASCOM driver may have crashed. This is ACP 6.0 build 11 with hotfix 4.0. There are no system or application error events in the eventvwr.

    Any ideas?

    Ajai

  2. #2
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    27,494

    Default

    Yes, you are on the right track. Some driver died. If I knew where and how you saw the error, the title bar or any popup dialog that may have contained that error, or if it is in the ACP console, the exact error message in its totality. I may be able to shed more light on it. Can you tell by ACP's behavior what failed?
    -- Bob

  3. #3

    Default

    Hi Bob,

    The error was a generic pop-up dialog box titled "ACP" with the following information:

    Run-time error '-2147467261 (80004003)
    Object reference not set to an instance of an object.

    ACP freezes (sidereal time stops updating) and when I click "OK" ACP goes away completely along with all object launched from ACP including weather watcher.

    I have tried rebooting the system and it is still happening.

    Ajai

  4. #4
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    27,494

    Default

    Start eliminating the possibilities. Does it happen with the scope connected? The Dome (maybe disable dome control temporarily?)? The focuser? The rotator if any? Something is dying. When did it start happening? What might have changed on the system that would cause it to start happening?
    -- Bob

  5. #5

    Default

    So far it only happens when I have the telescope and dome connected regardless of whether or not a script is being run. The camera does not have to be connected. I will try without the dome tomorrow (doing a run tonight). Nothing in the system has changed between when all was working and when I started to see the failure (not even a Windows update). I suspect the DDW driver....

  6. #6

    Default

    Ok it is the dome:

    (wait until 04:00:00 UTC)
    [**REFRESH TIMER EXCEPTION**]
    [Source: ASCOM.DigitalDomeWorks.Dome]
    [Object reference not set to an instance of an object.]
    [Phase = 5]
    **Script Error**
    Source: ACP
    Message: The script was aborted.

    Any idea what could be wrong?

    Ajai

  7. #7
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    27,494

    Default

    No clue, other than the usual suspects when some piece of hardware "suddenly stops working". Something in the driver is causing it to take a code path which resulkts in trying to use an object that hadn't been created yet or has died and its handle is no good. Source: ASCOM.DigitalDomeWorks.Dome means that the exception was thrown by code inside the DDW driver, not by ACP.
    -- Bob

  8. #8

    Default

    Ok thanks Bob. This time it didn't but the last time ACP crashed hard afterwards leaving the telescope tracking (the dome closes shortly after it loses contact).

  9. #9

    Default

    Hi Ajai,

    I was just wondering if you still have this problem or managed to solve it?
    We're having the same issue, and other than knowing it's something in the DDW driver I can't find anything that could be causing it.

    Thanks,
    David

  10. #10

    Default

    Hi David,

    No I have not been able to solve the problem. It will crash every time if I don't reboot the computer before each run. If I reboot the computer it works fine for one night's imaging. If I try for 2 nights it will crash about half way through. It appears to be behaving like either a memory or resource leak that occurs only in the 64-bit version of the dome driver.

    Ajai

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Dome control issue
    By smenaker in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 2
    Last Post: Apr 1, 2014, 01:48
  2. ACP 7 fails to close Digital Dome Works/Technical Invovations Dome.
    By Peter Prendergast in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 15
    Last Post: May 20, 2013, 00:26
  3. ACP Focus Issue
    By Jack Harvey in forum FocusMax and PoleAlignMax Questions
    Replies: 7
    Last Post: Nov 21, 2011, 22:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •