Results 1 to 10 of 22

Threaded View

  1. #1

    Default Foster Systems Roof Not Working With Scheduler 3.5

    I just moved up to Scheduler 3.5.1 and am now getting scheduler dead conditions. I believe the issue is somehow related to the rate at which the roll off roof controller is polled.

    The roof is issued a open command. The readback will be closed then go opening, and then back to closed then the roof controller relay finally clicks and starts to open and then roof condition is reporting opening again. This is with the Foster systems roll off roof controller. I think the query is happening too quickly and the sequence from the controller is confusing scheduler. Nothing has changed with the hardware and everything was working fine with Scheduler 3.4.

    Here is the short log results when the error occurs on evening startup.

    Todd



    Log opened at Fri, Apr 06 2012 19:41:40 UTC (actual time)Current log level is VerboseScheduler version 3.5.107-Apr-2012 02:14:13.8: ++ Observatory Startup ++07-Apr-2012 02:14:13.9: Start ACP Sequencer's StartupObs script07-Apr-2012 02:15:38.6: Open the observatory dome/roof07-Apr-2012 02:15:48.6: **Dome closed while opening. Assuming weather closure.07-Apr-2012 02:15:48.7: **EXCEPTION IN SCHEDULER:07-Apr-2012 02:15:48.7: **Dome failed to open for reason other than hardware weather closure07-Apr-2012 02:15:48.8: Traceback: at DC3.Scheduler.Engine.DoStartupIf(Boolean openDome) at DC3.Scheduler.Engine.Run()07-Apr-2012 02:15:49.0: Run statistics:07-Apr-2012 02:15:49.0: Observations: 14807-Apr-2012 02:15:49.0: Considered: 11007-Apr-2012 02:15:49.0: Completed: 7307-Apr-2012 02:15:49.0: Skipped: 007-Apr-2012 02:15:49.0: Never Eligible: 3807-Apr-2012 02:15:49.0: Failed: 3707-Apr-2012 02:15:49.0: Shutter-Open efficiency: 0.00-Apr-2012 02:15:49.0: Overall Efficiency: 0.00-Apr-2012 02:15:49.0: Release ACP sequencerLog closed at Sat, Apr 07 2012 02:15:50 UTC (actual time)
    Attached Files Attached Files

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Telescope Park problem: ACP 7, Autoslew, Foster Systems
    By William Martin in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 19
    Last Post: May 14, 2013, 23:44
  2. Foster Systems not working (was: Scheduler is hanging)
    By Bernard Miller in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 3
    Last Post: Oct 4, 2012, 03:16
  3. Problem with Foster Systems AstroMC 1.9.9a
    By Mike Pooler in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 10
    Last Post: Apr 19, 2012, 13:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •