Results 1 to 4 of 4
  1. #1

    Default FocusMax/RoboFocus Loses Position

    Hi All,

    Second post of the evening, I'm afraid; a frustrating time at the moment, with a couple of problems!

    I have enjoyed pretty much trouble-free autofocus with FocusMax and RoboFocus on my LX200. Occasionally, when using AcquireStar to focus, the RoboFocus driver seems to lose its' place; the position counter seems to be dropped, and a large, random focus movement results. If I don't notice and intervene manually, autofocus fails.

    Here's an extract from a FocusMax log showing a typical case:

    21:36:14 ** Beginning Focus run **
    21:36:14 LS: -0.226672 RS: 0.226798 PID: 1.40 NFHFD: 10
    21:36:14 Move direction: Out
    21:36:15 Filter = Unfiltered (slot 4)
    21:36:15 Current position = 7817
    21:36:15 Focus Start HFD: 20
    21:36:15 Min/Max flux setting = 100/300K
    21:36:15 Find star binning = 2x2
    21:36:15 Inital exposure = 1
    21:36:23 Could not calibrate image - check MaxIm Set Calibration window
    21:36:24 Focus binning = 1x1
    21:36:27 Decreasing exposure Time
    21:36:27 Total Flux = 1726467, next exposure = 0.12 sec
    21:36:30 Target star found at X = 342, Y = 220 Flux = 219405
    21:36:30 Focus exposure will be 0.12 sec
    21:36:30 Position , HFD , Mean Best Focus , X , Y , Flux
    21:36:30 7817 , 3.61 , 0 , 342 , 220 , 219405
    21:36:39 7745 , 9.10 , 0 , 338 , 217 , 205545
    21:36:39 On correct side of focus
    21:36:39 Moving to start HFD
    21:36:47 7697 , 10.62 , 0 , 336 , 225 , 72338
    21:36:54 Star is too close to frame edge or is too weak; increasing frame size
    21:36:54 Increasing frame width
    21:36:57 7656 , 27.60 , 0 , 337 , 217 , 195176
    21:37:12 7690 , 22.79 , 0 , 341 , 218 , 188544
    21:37:12 Move to Near Focus HFD
    21:37:25 7718 , 17.24 , 0 , 340 , 217 , 186947
    21:37:38 7 , 10.30 , 0 , 341 , 217 , 195425
    21:37:38 ** Starting Near Focus **
    21:37:38 Position , HFD , Mean Best Focus , X , Y , Flux
    21:37:38 7 , 10.30 , 52 , 341 , 217 , 195425
    21:37:40 7 , 10.50 , 52 , 342 , 218 , 179135
    21:37:44 7 , 11.62 , 54 , 343 , 218 , 186053
    21:37:47 7 , 11.05 , 54 , 342 , 218 , 189830
    21:37:50 7 , 11.02 , 54 , 341 , 218 , 201381
    21:37:50 Best Focus is: 54
    21:40:58 Star is too close to frame edge or is too weak
    21:40:58 Increasing frame width
    21:41:02 No star found

    You can see that, at 21:37:38 the focus position 'jumps' from 7718 to 7; this is not a commanded move, but results in a problem on the next focus move (in this case, when FocusMax commands RoboFocus to move to the best focus position of 54 units).

    This problem doesn't occur often - maybe once every five nights or so - but can obviously ruin a night's observing. I'd be grateful for any pointers as to where to start troubleshooting.

    Thanks in advance,

    Simon.

  2. #2
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    31,596

    Default

    FocusMax is a mystery sometimes. I'm going to move this to the FMx forum. You might want to post to the FMAX_UG group on Yahoo.

    I'm going to guess something occasionally slips in the imaging train? But I really don't know. For some reason it made that jump while it was setting up for the focus run. I don't know what's going on inside FMx at that point.
    -- Bob

  3. #3

    Default

    Bob,

    Sorry - I hadn't realised that there was a separate forum here for FocusMax questions.

    I've already posted to the FMx Yahoo! group; from comments I've received so far, I'm going to contact Technical Innovations (the vendor) for their comment.

    Thanks,

    Simon.

  4. #4
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    31,596

    Default

    Sounds like a logical starting place.
    -- Bob

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. scripting with robofocus
    By Pierre Tremblay in forum Add-Ons, Enhancements, and Helper Components
    Replies: 1
    Last Post: Oct 9, 2013, 00:55
  2. FocusMax & RCOS TCC -- FocusMax Will Not Close
    By Matt Russell in forum FocusMax and PoleAlignMax Questions
    Replies: 2
    Last Post: Mar 9, 2013, 20:08
  3. FocusMax/ROBOFocus connection issue
    By hclin in forum FocusMax and PoleAlignMax Questions
    Replies: 1
    Last Post: Mar 21, 2009, 13:12
  4. FocusMax User Group on Yahoo! - DOWNLOAD FOCUSMAX FROM HERE
    By Bob Denny in forum FocusMax and PoleAlignMax Questions
    Replies: 0
    Last Post: Oct 25, 2008, 22:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •