Results 1 to 2 of 2

Threaded View

  1. #1
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    31,580

    Default Planner 4.2 - Supports TheSky X

    ACP Planner 4.2 is now available, with support for TheSky X 10.1.10 or later (as well as TheSky 6). This version is also compatible with Windows 7/Vista 32- and 64-bit including ACP plan importing (which has a couple of other fixes). TheSky X 10.1.10 is available from Software Bisque's web site.

    http://download.dc3.com/ACPPlanner-4.2-Setup.msi

    ACP Planner 4.2 Release Notes (January 2011)

    This is a release for compatibility with TheSky X 10.1.10 or later. Previous versions of Planner worked only with TheSky 6. It also addresses installation and operation issues on Windows 7/Vista with User Account Control enabled, as well as additional installation issues on 64-bit systems.
    Critical:
    1. You may have to run TheSky X "as administrator" once to get its scripting support to register with the Operating System. Look in Program Files\Software Bisque\TheSky X Professional and find TheSkyX.exe. Right Click on it and select Run as Administrator. Let it come up and settle. Wait for 30 seconds then close TheSky X. You only have to do this once (if at all).
    2. Capture from telescope coordinates has been removed. It was not practical to support with TheSky X. Also, since Planner is designed as an offline tool with ACP, it makes little sense to capture targets from the live telescope position anyway. This simplified the controls as well as the logic in Planner. If you really need this, please contact DC-3 Dreams and we'll try to help.
    Product Improvements
    1. The Plan Capture and QuickCapture applets now detect and use TheSky X 10.1.10 or later. If TheSky X is present on the computer, it will be used in preference to TheSky 6. Therefore, if both are installed, these applets will only use TheSky X.
    Bug Fixes
    1. The Presets editor window now disables the filter selectors and Update button when there are no presets in the list. This corrects a possible fatal error, as well as making the behavior like the other windows.
    2. The error report text file resulting from a failed ACP Plan import has been moved from Planner's program folder to My Documents. This was needed for Windows 7/Vista with User Account Control on. You won't notice this change unless you go looking for the file later. It still appears in Notepad after the failed import.
    3. It is now possible to successfully import plans with naked deep-sky objects as targets (using MiniSAC).
    4. Importing ACP plans with time features enabled now properly ripples the target start times.
    5. The missing help page for adding/editing calibration frames has been created, added to the table of contents, and linked to the "help me" link on the Add/Edit Cal Frames window.
    6. The Plan Capture and QuickCapture applets will pop up a friendly/informative error message box if TheSky X has not been run as admin once to register its COM interfaces.
    7. The tooltip on the Presets list is now a balloon like the other windows.
    8. When saving observatory profiles, remove/replace illegal characters for file names when constrcting the proposed file name for the profile.
    9. Specified directory for cal frames has been fixed. It was missing from the generated plan.
    10. #count 1 and #repeat 1 directives are inserted to prevent target carry-over problems with plans which have a mixture of old- and new/compact-format targets.
    11. The plan compiler used by Planner for importing ACP plans has been separated from the one used by ACP. This prevents changes in one from affecting the other, and also prevents problems when installing a newer version of Planner or ACP on a machine with an older version of the other already installed.
    12. SkyTools importing documentation has been enhanced to describe the proper column scheme to use for importing, and giving a sample.
    13. The installer now handles Windows 7/Vista installations with User Account Control enabled. It also fixes a problem with installation on 64-bit systems.
    Last edited by Bob Denny; Feb 27, 2012 at 22:47. Reason: Remove note about TheSky 10.1.9, highlight 10.1.10.
    -- Bob

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ACP Planner & TheSky HD on the iPad
    By John Kasianowicz in forum ACP Planner
    Replies: 9
    Last Post: Nov 15, 2014, 15:57
  2. Replies: 6
    Last Post: Nov 21, 2010, 17:06
  3. [Solved - Not a Planner problem] Planner crash Win7
    By Larry Clark in forum ACP Planner
    Replies: 5
    Last Post: Oct 7, 2010, 15:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •