Results 1 to 2 of 2

Hybrid View

  1. #1
    Join Date
    Jul 2010
    Location
    Casa Grande, AZ
    Posts
    257

    Default ASCOM lost track of drivers?

    This is a weird one. I am running Win7, Ascom 5.51. Things have been running fine for awhile, I haven't done any updates (my Internet access is down).

    Last night I sit down to run some ACP scripts, and my ASCOM drivers are "gone" (they do not show up in the Chooser lists). A variety of Hubs are still present, but telescope and focuser drivers do not appear. FocusMax shows a number (perhaps 6-8) of blank entries in the front of the list of focusers; none of my actual focusers are listed (Optec and EasyFocus).

    The Ascom Profile shows things still present - as far as I can tell everything looks OK.

    I ran the Diagnostic tool, got the giant list of messages. Not sure what they are telling me. However, it looks like it is looking in both the Registry and the Profile system for settings. A number of Registry entries are reported as missing, such as "Focusers" and "Telescopes".


    One source of confusion - I thought the Registry isn't used any more for this? Everything is supposed to come from the Profile xml setup? Or do things have to appear in both places?

    I have a second system running Ascom under XP; same 5.5 version of Ascom (no ACP). The same thing happened on that system. No Focusers or Telescopes.

    Anyone experience anything like this? I looked around the Ascom site, didn't find anything like this. Also did not find information about what the Diagnostic tool is reporting or how to interpret its results.

    I have recently 1) installed Deep Sky Stacker, and 2) installed PoleAlignMax. Perhaps they have messed up the Ascom stuff? PoleAlignMax might be the more suspicious culprit - I don't see DSS doing anything with Ascom.

    I assume I will try and re-install the drivers tonight, maybe they will come back.

    Thanks in advance for any clues,
    brew

  2. #2
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    26,843

    Default

    2) installed PoleAlignMax
    Yep, that program's installer is evil. The ASCOM developers told the PAM authors about it and I thought they had fixed it. Meanwhile, I hate to ask you to do this, but I have an online appointment in less than an hour and need to eat dinner... Could you post this to the ASCOM Talk forum on Yahoo? Someone will know... and you might be able to find the solution via search.

    At a minimum, you might be able to re-run the installers for the drivers you need. That might refresh the data in the ASCOM chooser database. I would not uninstall anything just yet. The corruption from PAM might jhave made things get sick during uninstall...
    -- Bob

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. EM-200 track motor won't stop after Park
    By Yung Jung Chang in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 10
    Last Post: Dec 25, 2012, 02:34
  2. Where is the list of installed drivers?
    By Larry Simpson in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 7
    Last Post: Aug 19, 2010, 01:36
  3. Does it possible to track IIS and other satellites with ACP?
    By Anton Drokin in forum Pre-Sales Technical Questions and Help
    Replies: 1
    Last Post: Jun 3, 2010, 00:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •