Results 1 to 4 of 4

Hybrid View

  1. #1

    Question PlanChecker.js can't create object

    First time since a Windows 10 update last week I tried to check a plan and PlanChecker.js just fell over without showing any Notepad output. When I ran it in cmd prompt, it showed:

    C:\Program Files (x86)\ACP Obs Control\Planchecker.js(224, 1) Microsoft JScript runtime error: Automation server can't create object

    I tried re-registering dc3reg.dll, but no help. Line 224 seems to be instantiation of ACP.Plan.

    Need to check my plans as they run on a shared remote site with inflexible reservations.

    Any ideas or similar tales welcome.


  2. #2


    I've tried several things. Since the help file mentions that PlanChecker.js was designed to run on a machine without ACP installed, I moved it to a clean machine with ThinScript.dll registered and ASCOM installed, but otherwise similarly to my laptop, with up-to-date Windows 10.

    Exactly the same error, so why can't Cscript running PlanChecker.js create object ACP.Plan? Is there something else from ACP that is needed? Surely not a running ACP? My telescopes are overseas connected to other versions of ACP.

  3. #3


    Fixed it. ThinScript.dll was the wrong guess. I found a reference to registering Plan.wsc in an unrelated Customer Service post and that did the trick. Along with PlanChecker.js, Plan.wsc, which looks like it contains the external compiler, seems to be the only other file necessary to run the Plan Checker standalone on another Windows machine with ASCOM installed.

    When running 'regsvr32 Plan.wsc' the registration reports an entry in \Windows\System32\scrobj.dll, so it would appear that was affected by the Win10 update.

    Best to all,


  4. #4
    Join Date
    Oct 2005
    Mesa, AZ


    If you have ACP, then it has a repair function. However if you are running Planner on a separate computer (which is just fine!!) yea you may have been bit by a Windows update. It appears that Microsoft has stopped unregistering WSCs in their latest updates, so maybe this issue is behind us. Thanks for letting us know.
    -- Bob



Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts