Interesting observations. What puzzles me is that I used the Media Creator tool to download the latest Windows 10 (2004) image when I updated the home computer July 2nd and the observatory computer on July 14th. (Build 19041.388). I ran this as "update this PC" and not to create an ISO file. So it's hard for me to understand how this Windows Image could be corrupted in just a few weeks, considering your comment about years.

I have another question. If there are no other "failures" shown in CBS log, is it certain that there are no other issues with any other components of the Windows Image?

Before going on to do another MediaCreator ISO download, I tried another "experiment." Since I took permissions to modify the two relevant JET files in SysWOW64, I relocated the msjet40.dll to another folder (removed it from SysWOW64) and then re-ran sfc /scannow. I left msrd3x40.dll in place. I wanted to see what happens in this situation. If the missing file is replaced, the Windows Image is most likely not corrupted. If it's not replaced, then there is something wrong indeed with the Windows Image.

sfc /scannow only took about three minutes to run. I got the same messages from the command prompt window about "corrupt files." msjet40.dll was NOT written into the SysWOW64 folder! And the CBS.log file posted the same errors about a hash mismatch. I also ran sfc /scannow on the observatory computer. I got the same results. On both computers, the JET files were not replaced.

I'm moving on to your repair described above. I will post again after getting a new ISO image to rebuild the Windows Image, and running sfc /scannow once again.

I do have a philosophical question about all this. It's probably a stupid question - I do believe in having "good" software on board. But if only these two files are corrupted in the Windows Image, and I like the result that an update does not replace the Jet files, why would I want to repair the Windows Image file? At least for now? If I do, then it's only to have to go through the tedious tasks of either compressing the Scheduler database or retaking permissions and replacing the updated msjet... and msrd3x... files with the good old ones.

The real solution is of course in the hands of Bob and Microsoft.