Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2010
    Coonabarabran, NSW, Australia

    Default Troubles installing Scheduler on a Win7Ultimate machine

    Hello, I am having issues to get scheduler 8.3 working on a new PC using windows 7 ultimate SP1.
    I have opted to use the older Microsoft OS to avoid all troubles Win10 with its unstoppable updates is bringing.
    ASCOM installed is 6.4 SP1.
    ACP 8.3 installs and runs straight away, no problems.
    Problem is happening after I successfully install the Scheduler and then try to run it, correct. I don’t even get to input the license due to the error.
    Scheduler installs but as I try to run it I get an error message: Failed “as Administrator” check: reference not set to an instance of an object.
    As far as I know there is nothing special on the Windows version I have installed.
    I tried several changes without success:
    1) Changed login account from admin to standard user; still same error
    2) Created a new account called “Test” as a standard user; still same error
    3) Tried running Scheduler in various types of compatibility modes; still same error
    4) Tried to remove and reinstall EVERYTHING (including OS) couple times; still same error
    Is there anything I can try? Is there may be something related to the use of Win 7 ultimate perhaps that is not compatible ?
    Thanks for any reply given

  2. #2
    Join Date
    Nov 2015
    Christchurch, Dorset, United Kingdom

    Default Windows 7 Ultimate - Scheduler permissions.

    Hi Marco.

    Bob will most likely have to help you with this problem.

    The issue may be related to the use of Windows 7 Ultimate Edition which was an extra secure build of Windows 7 designed for large managed corporate networks.

    The answer might lie in the special ‘Applocker’ console that is enabled with Windows 7 Ultimate and contains permissions lists per-application that allow apps such as Scheduler to access parts of the OS considered security critical in corporate networks.

    As so few ‘ordinary’ users here will have used the extra secure Windows 7 Ultimate edition I doubt there will be many that have experience of app management on this platform.

    The I.T. dept of my employer distributed a few builds of Win7 Ultimate about 10 years ago and it was not a great success as it stopped our engineers running diagnostic software on the machines we were supposed to be maintaining and after just a few months I.T. reverted those machines back to Windows 7 Professional.

    Have a look at the Applocker console and see if you can add Scheduler to the whitelist, or remove any restrictions already applied to Scheduler, if present. Also, right-mouse-click Scheduler.exe and check permissions are set correctly and that Scheduler is not configured to run with permanent administrator rights.

    My memory of the Applocker setup and Windows 7 Ultimate is rather sketchy I’m afraid as I only used it for a few weeks, you will have to search on-line for Applocker instructions or wait for Bob to help.


  3. #3
    Join Date
    Feb 2010
    Coonabarabran, NSW, Australia


    Hi William, thanks for your feedback. In fact I have reinstalled everything from scratch and replaced the OS with a Windows 7 professional license I had. All works now! So I believe your diagnose is correct, there is an incompatibility between Scheduler and Windows 7 ultimate unless something is modified or set in the OS. I am happy to have solved the issue using the professional version of Win7, I hope this experience will help other users that may have the same issue, even if I believe many nowaday are opting to use Windows 10 (which has its own issues as well..).
    Denny, you may want to keep this in mind in case anybody else may have similar troubles, Windows 7 Ultimate is not the right choice to install Scheduler unless you want to investigate deeper on a dedicated solution !
    Clear skies

  4. #4
    Join Date
    Oct 2005
    Mesa, AZ


    Thanks for Trying William!! Marco, good news! I have no access to Windows 7 Ultimate. The check that was failing is the one used to tell if the user started Scheduler to run "as Administrator". I believe the Windows API I use to test that is not present on Ultimate, but I have no way to tell.
    -- Bob



Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Installing Scheduler
    By Peter Pannozzo in forum Pre-Sales Technical Questions and Help
    Replies: 3
    Last Post: Mar 3, 2014, 14:24
  2. Troubles Posting with IE9?
    By Todd Benko in forum Help Using the Comunication Center
    Replies: 12
    Last Post: Jun 15, 2012, 15:42

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts