Hi Bob, this is an interesting mystery! I'm continuing some tests here that may help and have at least one more I should do before risking wasting your time on it. For example, I found that my APCC was ramping up to 25% CPU and holding there after a couple of hours whenever connected to the AP V2 driver, becoming unresponsive, and then ACP would report a lost connection to the mount. I also noticed that the feature that automatically parks the mount when comms are lost with APCC wasn't working. And there is more but I'll try to keep this short. I tried uninstalling and reinstalling AP V2 and APCC. No change. I tried rolling back to an earlier version of AP V2 and APCC no change. I tested with and without ACP connected to see if APCC would still get unresponsive after a couple of hours- it did. I tried APCC without AP V2 connected to see if it would get unresponsive after a couple of ours. Breakthrough! Without AP V2 connected to APCC, APCC stayed happy and stable. So, I decided to *completely* uninstall AP V2 and APCC right down to their data folders and libraries. Then I reinstalled AP V2 and APCC from scratch, reconfiguring from zero. Interestingly, the "mount disconnect" problem APC had been reporting periodically vanished, APCC no longer ramps up to 25% CPU and becomes unresponsive, and the mount now parks automatically if I break the connection from it to APCC. Now I'm dying to see if the comet tracking clears up and plan to do that test tonight. I can't conceive of any reason why any of these things are related, nor can I imagine why a complete uninstall and reinstall of AP V2 and APCC would fix those other issues, but fix them it did so something must have been wrong in there somewhere.

I'd like to do the comet testing test again tonight to see if that has changed after my work on AP V2 and APCC. I'll report back after that test is done.

Sound like a good plan?