I have difficulties with the old RCOS focuser/rotator to talk with FocusMax V4 and ACP. It does not connect easily and now and then it just stops talking to the ASCOM interface. When this happens FocusMax gives an error "An action cannot be completed because a component (RCOS) is not responding.". There is no way out of this without stopping all the processes and starting all over.

ACP freezes when this happens, no response whatever: no updates on screen or response on mouse clicks. It also has to be stopped by force and restarted.

On the meanwhile RCOS control software is still running and it can be connected with my simple script:

Set f=CreateObject("RCOS_AE.Focuser")
msgbox("Focus position="+cstr(f.position))
So it is alive and kicking. Also the telescope focus can be still changed with it so it also talks to the hardware. There are never any errors shown in the RCOS TCC.

I have tried to debug this by putting ASCOM Pipe between FocusMax V4 and RCOS TCC. But it just shows the same error message. Anything else I could try? All this worked well many years in WinXP (ACP 4.2 and FocusMax 3) with the same hardware.