Results 1 to 6 of 6

Hybrid View

  1. #1
    Join Date
    Jul 2006
    Location
    Hoogeveen, the Netherlands.
    Posts
    24

    Default Telescope, SlewToAltAzAsync command failed

    Hello,
    My backyard observatory is working fine with ACP Expert Scheduler.
    When I run AutoFlat.vbs, flats are taken successfully with no error.

    Now I would like to take flats after an imaging session.
    When I run "Test Dawn Flats" from the Utility menu in the ACP Expert Scheduler program window,
    the following error is displayed in the console output window:

    19:53:40 Aiming scope at light source or screen
    19:53:40 **Script Error (Tracking has been stopped)**
    19:53:40 Source: On_Cue_On_Step
    19:53:40 Message: Telescope, SlewToAltAzAsync command failed
    19:53:40 Location: line 804 column 13.

    It seems like the OnStep ASCOM driver is the problem, but I don't know what is causing the error.

    I attached the logfile and my AutoFlatConfig.txt

    Kind regards,
    Emiel Kempen
    Attached Files Attached Files

  2. #2
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    27,240

    Default

    Hi -- The error is coming from the On_Cue_On_step which I assume is a telescope mount control system? I can think of a couple of reasons but I am guessing:

    1. The alt/az for the light panel is outside the range of permitted altitude for slews
    2. The mount cannot do Alt/Az slews but is reporting to ACP (through its ASCOM interface that it can do them). ACP believes this and will call SlewToAltAz. If the scope reports that it cannot SlewToAltAz, then ACP will call back to multiple RA/Dec slews to get to that altz the hard way.
    -- Bob

  3. #3
    Join Date
    Jul 2006
    Location
    Hoogeveen, the Netherlands.
    Posts
    24

    Default

    Hi Bob,
    Thanks for the info, yes On_Cue_On_Step is a telescope control system, also called OnStep.
    I will ask on the OnStep forum.
    Emiel

  4. #4
    Join Date
    Jul 2006
    Location
    Hoogeveen, the Netherlands.
    Posts
    24

    Default

    Hello Bob,
    Howard Dutton, the developer of the OnStep telescope controller, wrote a revised ASCOM driver, it is working fine now.
    Emiel.

  5. #5
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    27,240

    Default

    You might advise him to use the ASCOM Conformance Checker to avoid future surprises like that.
    -- Bob

  6. #6
    Join Date
    Jul 2006
    Location
    Hoogeveen, the Netherlands.
    Posts
    24

    Default

    I will :-)
    Emiel.

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Scheduler Failure due to telescope limits: TheSky X Telescope Limit
    By Peter Brackenridge in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 10
    Last Post: Aug 21, 2019, 13:38
  2. Connecting the telescope and dome in ACP failed sometimes
    By Shai Kaspi in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 6
    Last Post: Jun 22, 2015, 22:07
  3. Telescope.Connected = true Fails to connect telescope
    By Gerald Ruch in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 5
    Last Post: Jul 25, 2012, 15:49
  4. Scheduler Failed to connect Telescope after Weather Safety
    By Peter Prendergast in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 16
    Last Post: Apr 3, 2012, 01:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •