Results 1 to 10 of 15

Threaded View

  1. #10
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    26,393

    Default

    Ok, this is sort of crazy. I'm uncomfortable.

    I'm Emanuele and I wrote the user interface and the ASCOM driver for RotoFoc (focuser and rotator).
    Unfortunately our ASCOM interface implements 5.5 ASCOM version and doesen't implement any shutdown or custom command.
    ASCOM 5.5 is ten years old. So this must be a very old device. And yes there is no ASCOM standard for shut down because no other focuser needs to be called to "shut down" separately from the standard Connected = False. That should be used to do whatever the device needs. I sense, however, that these people are not going to do any more programming because they are already 10 years out of date on the ASCOM Platform.

    If you want to drive the device without ASCOM, you need to use a custom protocol defined in the document attached to this email (please note: the protocol is "as is" and without support and warranty).
    Sorry but I am not going to get into programming low-level serial commands to a device. It is effectively just another driver and I am not a driver writer for other companies. I have attached the document but I strongly recommend against trying to implement this, especially since they immediately say they won't help you if you have a problem! I will certainly not become involved in programming this sort of thing.

    But if you need to use ASCOM driver, we need to define a special command to implement this behaviour. My purpose is this: before shutdown the system, you must call the ASCOM method "Move(long step)" with "step" = MAXLONG (=2147483647) (this number "probably" is an invalid step number).
    This is not the "best" solution and it is not ASCOM compliant. But this could be a simple workaround.
    OK, this is also against ASCOM rules. Note that ACP accesses the Focuser through FocusMax, and I am pretty sure trying to set the focuser to this huge (and bogus) value will trigger an error in FocusMax before it gets to the focuser.

    My recommendation - especially if your observatory is going to be a part of "Project X" (if you know what I mean) - is to get a solid focuser that is supported by the company and which is reuly ASCOM compliant. I cannot support you with this focuser.
    Attached Files Attached Files
    -- Bob

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rotator Lossing Connection
    By Steve Reilly in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 4
    Last Post: May 10, 2018, 17:06
  2. Rotator & focuser problem !!! (same device)
    By nikos paschalis in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 28
    Last Post: Mar 25, 2017, 11:56
  3. FocusMax drops focuser connection
    By Christopher Cappelli in forum FocusMax and PoleAlignMax Questions
    Replies: 5
    Last Post: Dec 4, 2014, 02:00
  4. FocusMax/ROBOFocus connection issue
    By hclin in forum FocusMax and PoleAlignMax Questions
    Replies: 1
    Last Post: Mar 21, 2009, 13:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •