Results 1 to 6 of 6
  1. #1

    Default FS-2 No Longer Supported?

    Hi,

    I upgraded to ACP8.2 (from ACP8.0) and to MaximDL6.20 a few days ago, and I am getting the following error for every script which I am running (e.g., AutoFocus.vbs, AutoFlats.vbs, FindLostScope.vbs, etc.):

    Initializing AcquireSupport V8.2.10
    Weather safe, server is Boltwood Cloud Sensor II
    Telescope is ACP->LXP, driver V1
    Dome is Digital DomeWorks
    MaxIm DL is version 6.20
    Imager is QSI Universal
    Using focus offsets and star mags from FilterInfo.txt
    Selecting filter clearx from previous ACP run at 20190425@205438 UTC
    Imager readout modes:
    0 is Use Adv Dialog
    1 is Image Quality
    2 is Fast Readout
    Guider is SBIG Universal (no rotator)
    Guider plate scale unknown, guided dither with guider pixels
    Max unguided exposure 60 sec.
    (assuring that FocusMax is running now...)
    Calculated unbinned plate scales (arcsec/pix): H = 0.89 V = 0.89
    Calculated field of view (arcmin): H = 49.1 V = 37.0
    Plate solving with GSC 1.1 (ok for wider fields)
    **Script Error**
    Source: ACP Telescope Controller
    Message: Property Get CanSetRightAscensionRate is not implemented. The selected telescope's driver is ASCOM V1


    I have no idea what that message means. We are using a custom made telescope mount that runs FS2 as the telescope drive unit and it is defined in ACP with the ASCOM driver "Generic LX200 Protocol Telescope". The FS2 does not have the ability to stop the tracking of the telescope (telescope is continuously tracking as long as the FS2 is powered). We are using ACP on that telescope for more than 15 years and I do not recall that we ever had such a problem before.

    Any help to solve that issue will be appreciated.
    Thanks,
    Shai

  2. #2
    Join Date
    Nov 2008
    Location
    Albuquerque(me) / Rincona(scope), NM
    Posts
    679

    Default

    I see you're running up-to-date MaxIm. Are you also running up-to-date ASCOM platform and telescope drivers?
    New Mexico Mira Project, Albuquerque NM

  3. #3

    Default

    The ASCOM platform we are using is 6.3. When I try the "Check for Updates" from ASCOM I am getting "Failed to contact the update server". I now realized that the ASCOM platform 6.4SP1 is current. I guess I need to install this ? .
    As for the telescope drivers: we are using a 20 years old FS2 system and I do not think it has any upgrades. The ASCOM driver "Generic LX200 Protocol Telescope" that we are using with it may have an upgrade but I am hesitant to use it since I am not sure it will work with my VERY old FS2 system.

    Shai

  4. #4
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    26,875

    Default

    Hello Shai --

    I am very sorry.

    Property Get CanSetRightAscensionRate is not implemented. The selected telescope's driver is ASCOM V1

    This means that your FS2 is so old in its ASCOM implementation that it can't be used with ACP 8.1 or 8.2. We no longer support Telescope V1 devices. It has been over many years since the FS2 was made, the last firmware revision iis 21.12.09 V1.26 from 10 years ago. Do you have this latest firmware?

    If you want to try this patch to AcquireSupport.wsc. perhaps it may allow ACP 8.2 to work:

    Locate this statement in c:\Program Files (x86)\ACP Obs Control\AcquireSupport.wsc.

    If Telescope.CanSetTracking And Telescope.CanSetRightAscensionRate And Telescope.CanSetDeclinationRate Then

    Change to

    If False Then

    There may be other problems as well but this is one we can bypass. You will be responsible for making this change again in future ACP updates, so please keep a record of this.
    -- Bob

  5. #5

    Default

    Hello Bob,

    Thank you for this patch to AcquireSupport.wsc . I applied it and our system seems to be working fine now. I am able to run the scripts I need with no problem and the scheduler is working fine running OK on the whole process. I just finished a successful run of a few hours of observations.

    I am not sure abot the firmware version that we have for FS2 and will need to study this, though I think I know we did not update the firmware in the past two decades. I am also not sure that our FS2 can accept the most up-to-date firmware. I will need to study this issue. Will the new firmware will change the FS2 from Telescope V1 device to a device that ACP8.2 (and later) is supporting?

    I wonder if I can go back in the ACP version from 8.2 to 8.0 which we know can work with our FS2? This is not not needed right now since I applied the patch, but might be needed if there will be other problems (as you noted), or in future releases of ACP this will not work any more, or there will be more changes that we will not be able to cope with, and we will want to go back in the ACP version after we install the new version. Is this something that can be done? Do I only need to run the old version installation file, same as running the new one, or is there something that will block the going back in versions?

    Thanks again for the help,
    Shai
    Last edited by Shai Kaspi; May 11, 2019 at 07:46.

  6. #6
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    26,875

    Default

    Excellent! Thanks for letting us know Shai.
    -- Bob

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •