Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Hybrid View

  1. #1
    Join Date
    Jan 2018
    Location
    Louisa, VA
    Posts
    182

    Default ACP Stalled due to Maxim-DL "Infinite" Download time.

    I think this has been discussed here before and I know that my county neighbor and imaging mentor, Steve Reilly has rarely had this problem as well without a clear-cut cause or resolution. It may well be a Maxim-DL issue, in fact I bet that it is, but I thought I'd post here first. Last night I got up at 3:45 and checked on the status of things. ACP had been frozen for 3 hours, apparently waiting for a Maxim-DL image download. Maxim-DL appeared to be frozen as well, and reported that it was "downloading" and the cooler was "off." This is the first time that I have experienced this in over a year of imaging. Ultimately, I had to shut everything down and restart, and then Scheduler/ACP/Maxim-DL worked fine for the rest of the night. I do not believe this is a USB cabling issue or a power issue. A few months ago I updated the power supply when I was having sporadic issues with cooler shutdown at 100% power, so there's plenty of power now. The USB cable run is short with solid connections. I'd appreciate any thoughts or updates and I'll post this on the Diffraction website as well. Thanks!
    Tech. Innovations 10' Pro Dome
    Astro Physics 1600 GTO mount
    PlaneWave 17" CDK scope
    SBIG STXL 16200 camera
    SBIG AO-X adaptive optics
    SBIG FW8G-STXL filter wheel / guider
    Maxim-DL / The Sky X
    FocusMax / CCDInspector
    ACP Expert

  2. #2
    Join Date
    Apr 2013
    Location
    Milton, ON, Canada
    Posts
    898

    Default

    Stacey, please post over on https://forum.diffractionlimited.com and we'll have a look. Make sure to tell us what version of MaxIm you are running.

  3. #3
    Join Date
    Jan 2018
    Location
    Louisa, VA
    Posts
    182

    Default

    Quote Originally Posted by Colin Haig View Post
    Stacey, please post over on https://forum.diffractionlimited.com and we'll have a look. Make sure to tell us what version of MaxIm you are running.
    Done, thanks!
    Tech. Innovations 10' Pro Dome
    Astro Physics 1600 GTO mount
    PlaneWave 17" CDK scope
    SBIG STXL 16200 camera
    SBIG AO-X adaptive optics
    SBIG FW8G-STXL filter wheel / guider
    Maxim-DL / The Sky X
    FocusMax / CCDInspector
    ACP Expert

  4. #4
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    26,843

    Default

    Thanks Coloin and Stacy! I lose sleep over these sorts of things, and when they are "rare" it's so damn difficult to zero in on them.
    -- Bob

  5. #5
    Join Date
    Jan 2018
    Location
    Louisa, VA
    Posts
    182

    Default

    Quote Originally Posted by Bob Denny View Post
    Thanks Coloin and Stacy! I lose sleep over these sorts of things, and when they are "rare" it's so damn difficult to zero in on them.
    Of course, everything ran perfectly last night. The sky was clear all night and the seeing was excellent for a change. These sporadic things are really tough to nail down!
    I've posted about this over on the Diffraction Limited / Maxim forum.

    I know you HATE "mopping up" others' problems and I fully agree, but I'm wondering if there's an easy way for ACP to throw an "Operator Intervention Needed" exception and shut things down when Maxim or other imaging software doesn't respond after a reasonable time? I'm just not thrilled with the idea that the dome stays open when this rare event happens.

    Thanks for all your help. I'm looking forward to the new videos and will see you at NEAIC.
    Tech. Innovations 10' Pro Dome
    Astro Physics 1600 GTO mount
    PlaneWave 17" CDK scope
    SBIG STXL 16200 camera
    SBIG AO-X adaptive optics
    SBIG FW8G-STXL filter wheel / guider
    Maxim-DL / The Sky X
    FocusMax / CCDInspector
    ACP Expert

  6. #6

    Default

    Stacey, I was getting very similar behavior, and fairly repeatable, too, when operating on short (< 5s) exposures.

    The one change I made that solved this for me was lowering the MaximDL "Limit resident image buffers" setting here:

    luBBtL3.png

    ...to something lower. YMMV of course, but that got things running smoother for me.

  7. #7
    Join Date
    Nov 2008
    Location
    Albuquerque(me) / Rincona(scope), NM
    Posts
    675

    Default

    When I ran ACP on Windows 7, these problems always (3 or 4 times) coincided with Windows Update(s) pending--seemed to get worse ~ last summer. Updates didn't even have to have downloaded yet. Well, it's worth checking.

    (I haven't run ACP on Win 10 Pro long enough to know if that solves it.)
    New Mexico Mira Project, Albuquerque NM

  8. #8
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    26,843

    Default

    Just so you know, I will do anything (within reason) that Diffraction/SBIG says I need to do if I'm somehow abusing or misusing the MaxIm API.
    -- Bob

  9. #9
    Join Date
    Apr 2013
    Location
    Milton, ON, Canada
    Posts
    898

    Default

    Just to chime in from Diffraction Limited, we want to hear about any issues, so we can find solutions together.
    Go here:
    https://forum.diffractionlimited.com/
    for help - I won't always catch it here on forums.dc3.com.

    Recent updates:
    SBIG cameras: February 12 - updated SBIGUDrv and firmware for certain SBIG camera models.
    Aluma cameras: March 15 - updated DL Imaging drivers and firmware - performance improvements, quieter fans, and binning/guide port fixes based on user input.
    MaxIm DL Pro: 6.20 is the current version; 6.21 will address issues with photometric data analysis and enhanced automation debugging to help with ACP issues.

    Three of the staff (myself included) have started doing Teamviewer sessions to track down really obscure issues, and we're happy to do so with any of you.

    I'd like to extend our thanks to the people who have reached out on an issue, and provided quality data, complete logs, complete system information, and patience while we work through the obscure issues together. Thank you!

  10. #10
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    26,843

    Default

    You guys are the greatest! It can be a rough road. And Colin I am truly thrilled to have you as part of the team there.
    -- Bob

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •