Mike, I think you are barking up the wrong tree, and DO NOT put coating on the electronics.

There should be enough heat in the camera to keep any moisture off, and this isnt behaving like a moisture problem, this is behaving like a USB problem.

You need to go about this step-by-step, methodically. Process of elimination.

Start by posting a photo of your whole setup, showing how you've run the cables and secured them.
It could be as simple as the camera power cable and USB cable is flexing and disconnecting/reconnecting during movement.

Take a short, passive cable, and connect the camera to the PC on the "workbench".
Download 100 images or so in MaxIm on its own.
Once you know that works, turn the camera over - and then run test again. Will simulate your rotation.
There is no vibration during the rotate as the camera isnt doing anything but cooling.

Make sure you have turned off Windows Power Management - USB Selective Suspend on the USB Root Hubs, the USB Hubs, and that includes the USB 3 extender cable. And any devices such as serial power / usb adapters etc.

Suggest you also download Microsoft USBView and make sure that the camera is not sharing a USB bus with other devices.

I looked through a bunch of your threads and could not figure out which camera you have. Which is it?

If it's a ZWO ASI 1600, get the latest ASCOM driver for it as there are fixes for that camera - v1.0.3.22 and the camera driver v3.0.0.5.
Also, for ZWO, lower the USB bandwidth to 40%.

Good luck.