Results 1 to 5 of 5

Hybrid View

  1. #1
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    23,036

    Default SOLVED: Microsoft releases new KB patches for all versions of Windows 10

    Microsoft has released KB patches for all versions of Windows 10 and Windows Server 2016. Here are the notes for the latest (1709, Windows Creators Edition). Per the release notes this fix is included

    Addresses issue originally called out in KB4056892 where calling CoInitializeSecurity with the authentication parameter set to RPC_C_AUTHN_LEVEL_NONE resulted in the error STATUS_BAD_IMPERSONATION_LEVEL.
    This removes the need to change the DCOM Authentication level as described in our previous post here. As yes we don't know if the Authentication level will need to be restored back to the original level of "None". We'll report back when the results are in.
    -- Bob

  2. #2

    Default

    Bob, do we know as yet whether the DCOM Authentication needs to be changed back again. I had to manually install the update yesterday but haven't had a chance to test things. I am still only having trouble with the TCS.exe telescope program which doesn't connect via USB ( although I can send it commands through the serial monitor still) . I have sent the hardware away for testing but hadn't thought the issue was related to this as there wasn't anything in DCOM related to TCS.exe, only things were the ASCOM simulators, ACP and SkyX

  3. #3
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    23,036

    Default

    Iím a bit unclear on your post with regard to TCS and simulators, bit so far it looks like the new update allows things to run as is. Me? I would reverse the changes and go back to None since that is what it has been for 10+ years.
    -- Bob

  4. #4

    Default

    I donít recall now if TheSkyX and ASCOM simulator settings were Off or Default or does it even matter

    re the TCS.exe I think I am grasping at straws as to why this software isnít working and whether it is related to the changes I made in DCOM- I suspect it isnít

  5. #5
    Join Date
    Oct 2005
    Location
    Mesa, AZ
    Posts
    23,036

    Default

    The original settings in TheSky were for "None". I suspect "Default" is OK as well. But using the ASCOM-supplied tool allows you to restore back to "none". I would set TheSky ones to "None".

    Or... try it all out and if it's working, just leave it alone.
    -- Bob

 

 

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Windows 10 uninstall reinstall problems - a fix from Microsoft
    By Colin Haig in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 1
    Last Post: Jan 3, 2017, 22:41
  2. Windows MUI error after weather unsafe [solved]
    By TRAPPIST in forum Hardware/Software/Driver Topics Not Directly Related to Our Software
    Replies: 14
    Last Post: Nov 17, 2016, 19:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •